Have you heard about the New PCI Deadline?

13 Jan Have you heard about the New PCI Deadline?

In short, this change to PCI security requirements has deemed that SSL encryption, which has been the standard for decades, is no longer PCI compliant due to vulnerabilities in this protocol. This means that virtually every POS system older than a few months will require a costly security upgrade no later than June 2018.

Harbortouch offers a secure, PCI Compliant solution to replace your current POS system!

• No Up-front Costs
• New hardware, software, training and installation
• Low Monthly starting at just $39/month
• 24/7 Support Harbortouch
• Lifetime Warranty

 

Call us today!!! 866-286-8744

No Comments

Post A Comment